#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\s|^)(?!(?:elem|asdf)?-)([\w-]+)\b"
Local $sString = "any-dashed-strings" & @CRLF & _
"this-can-be-matched-even-though-its-big" & @CRLF & _
"elem-this-cannot-be-" & @CRLF & _
"-" & @CRLF & _
"asdf-this-cannot-be-matched" & @CRLF & _
"-this-cannot-be-matched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")