import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^)(?!(?:elem|asdf)?-)([\\w-]+)\\b";
final String string = "any-dashed-strings\n"
+ "this-can-be-matched-even-though-its-big\n"
+ "elem-this-cannot-be-\n"
+ "-\n"
+ "asdf-this-cannot-be-matched\n"
+ "-this-cannot-be-matched";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}