$re = '/(?:\s|^)(?!(?:elem|asdf)?-)([\w-]+)\b/m';
$str = 'any-dashed-strings
this-can-be-matched-even-though-its-big
elem-this-cannot-be-
-
asdf-this-cannot-be-matched
-this-cannot-be-matched';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);