# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!kr\.|ps\.)(?<=\.|\?)\h+(?=[A-Z])/\n/gm;t' <<< "Hello, my name is Thomas. I found a pen on your website. I want to ask a question about the price. It costs 1.500.000 kr. Which I find a very expensive? ps. my full name is Thomas M. lastname. "