# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!kr\.|ps\.)(?<=\.|\?)\h+(?=[A-Z])"
test_str = "Hello, my name is Thomas. I found a pen on your website. I want to ask a question about the price. It costs 1.500.000 kr. Which I find a very expensive? ps. my full name is Thomas M. lastname. "
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.