import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!kr\\.|ps\\.)(?<=\\.|\\?)\\h+(?=[A-Z])";
final String string = "Hello, my name is Thomas. I found a pen on your website. I want to ask a question about the price. It costs 1.500.000 kr. Which I find a very expensive? ps. my full name is Thomas M. lastname. ";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}