#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z0-9]+)([\.{1}])?([a-zA-Z0-9]+)\@nuv([\.])ac([\.])in"
Local $sString = "google@nuv.in" & @CRLF & _
"google@gmail.in" & @CRLF & _
"google@gmail.com" & @CRLF & _
"google@nuv.ac.in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")