$re = '/([a-zA-Z0-9]+)([\.{1}])?([a-zA-Z0-9]+)\@nuv([\.])ac([\.])in/';
$str = 'google@nuv.in
google@gmail.in
google@gmail.com
google@nuv.ac.in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);