package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z0-9]+)([\.{1}])?([a-zA-Z0-9]+)\@nuv([\.])ac([\.])in`)
var str = `google@nuv.in
google@gmail.in
google@gmail.com
google@nuv.ac.in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}