#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *\"(\w(?!ness))*\".*$"
Local $sString = "{" & @CRLF & _
" "welcome": 1," & @CRLF & _
" "epic": 1," & @CRLF & _
" "awesomeness": 1," & @CRLF & _
" "tallnesses": 1," & @CRLF & _
" "nest": 1" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")