const regex = new RegExp('^ *\\"(\\w(?!ness))*\\".*$', 'gm')
const str = `{
"welcome": 1,
"epic": 1,
"awesomeness": 1,
"tallnesses": 1,
"nest": 1
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}