package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`//s3\.amazonaws\.com/[.A-z0-9-]+\/?`)
var str = `//s3.amazonaws.com/bucket.name/
//s3.amazonaws.com/bucket-name-here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}