const regex = new RegExp('//s3\\.amazonaws\\.com/[.A-z0-9-]+\\/?', 'g')
const str = `//s3.amazonaws.com/bucket.name/
//s3.amazonaws.com/bucket-name-here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}