re = /\/\/s3\.amazonaws\.com\/[.A-z0-9-]+\/?/
str = '//s3.amazonaws.com/bucket.name/
//s3.amazonaws.com/bucket-name-here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end