using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^[]+]*|.*?\[.*?\].*?)\]|(""(?:.|[\n])+)";
string input = @"[TSLA] [Model-ST[3000]123] ""(Model:""3000""),
(""Tesla"":""CyberTruck""),
(""Tesla"":""Model(y)""),
(""Tesla"":""Battery-Day";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}