// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[([^[]+]*|.*?\[.*?\].*?)\]|("(?:.|[\n])+)"#).unwrap();
let string = "[TSLA] [Model-ST[3000]123] \"(Model:\"3000\"),
(\"Tesla\":\"CyberTruck\"),
(\"Tesla\":\"Model(y)\"),
(\"Tesla\":\"Battery-Day";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}