$re = '/\[([^[]+]*|.*?\[.*?\].*?)\]|("(?:.|[\n])+)/m';
$str = '[TSLA] [Model-ST[3000]123] "(Model:"3000"),
("Tesla":"CyberTruck"),
("Tesla":"Model(y)"),
("Tesla":"Battery-Day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);