use strict;
my $str = 'See Holiday in v. Marriot (2002)
e.g. FB v. Google (2012)
; Yahoo! v. Microsoft (2000)
I.B.M. v. H.A.L (2001)';
my $regex = qr/(?s)\b[A-Z][A-Z.]*[^A-Z]*v\..*?\(\d{4}\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}