re = /(?s)\b[A-Z][A-Z.]*[^A-Z]*v\..*?\(\d{4}\)/m
str = 'See Holiday in v. Marriot (2002)
e.g. FB v. Google (2012)
; Yahoo! v. Microsoft (2000)
I.B.M. v. H.A.L (2001)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end