// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)\b[A-Z][A-Z.]*[^A-Z]*v\..*?\(\d{4}\)").unwrap();
let string = "See Holiday in v. Marriot (2002)
e.g. FB v. Google (2012)
; Yahoo! v. Microsoft (2000)
I.B.M. v. H.A.L (2001)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}