const regex = /^(?:.*(?!\.com)\.\w+|.*[0-9-].*)\r?\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*(?!\\.com)\\.\\w+|.*[0-9-].*)\\r?\\n', 'gm')
const str = `asd.com
ass.net
sdf.info
as-er.net
019-ne.com
012.com
01dc.net
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}