re = /^(?:.*(?!\.com)\.\w+|.*[0-9-].*)\r?\n/m
str = 'asd.com
ass.net
sdf.info
as-er.net
019-ne.com
012.com
01dc.net
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end