$re = '/^(?:.*(?!\.com)\.\w+|.*[0-9-].*)\r?\n/m';
$str = 'asd.com
ass.net
sdf.info
as-er.net
019-ne.com
012.com
01dc.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);