using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""url"":""(.+\/([0-9]{10})\/.+access_token=(.+?))""";
string input = @"Api::log : {""url"":""https://api.test.com//v0/notes/1113321569/notes?access_token=eyJhbGciOiJSUzI1NiJ9.eyJydGUiOiIxNTYyMDM5NjUxNDgxIiwidXNlcl9pZCI6MTAzMTU1MzI0MywidXNlcl9""
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}