package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)"url":"(.+\/([0-9]{10})\/.+access_token=(.+?))"`)
var str = `Api::log : {"url":"https://api.test.com//v0/notes/1113321569/notes?access_token=eyJhbGciOiJSUzI1NiJ9.eyJydGUiOiIxNTYyMDM5NjUxNDgxIiwidXNlcl9pZCI6MTAzMTU1MzI0MywidXNlcl9"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}