import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"url\":\"(.+\\/([0-9]{10})\\/.+access_token=(.+?))\"";
final String string = "Api::log : {\"url\":\"https://api.test.com//v0/notes/1113321569/notes?access_token=eyJhbGciOiJSUzI1NiJ9.eyJydGUiOiIxNTYyMDM5NjUxNDgxIiwidXNlcl9pZCI6MTAzMTU1MzI0MywidXNlcl9\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}