#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})"
Local $sString = "39 w. 38th Street, 10th Floor, NY, NY 10018" & @CRLF & _
"39 w. 38th Street, NY, NY 10018"
Local $sSubst = "$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)