package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})`)
var str = `39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018`
var substitution = "$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>"
fmt.Println(re.ReplaceAllString(str, substitution))
}