import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#\\w+(?=[^\\}]*?\\{)";
final String string = "body {\n"
+ " color: #FF0000;\n"
+ "}\n\n"
+ "html #ffffff .wahtever {\n"
+ " background: #eee;\n"
+ "}\n\n"
+ "#ffffff.test \n"
+ "{\n"
+ " color: #ffffff;\n"
+ "}\n\n"
+ "@media screen, print {\n"
+ " #ffffff.test {\n"
+ " color: #ffffff;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}