re = /#\w+(?=[^}]*?{)/m
str = 'body {
color: #FF0000;
}
html #ffffff .wahtever {
background: #eee;
}
#ffffff.test
{
color: #ffffff;
}
@media screen, print {
#ffffff.test {
color: #ffffff;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end