$re = '/#\w+(?=[^}]*?{)/m';
$str = 'body {
color: #FF0000;
}
html #ffffff .wahtever {
background: #eee;
}
#ffffff.test
{
color: #ffffff;
}
@media screen, print {
#ffffff.test {
color: #ffffff;
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);