package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bSHOW:\s+(.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b`)
var str = `SHOW: Game of Thrones 7:00 PM EST
SHOW: The Outsider 3:00 PM EST
SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}