# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bSHOW:\s+(.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b"
test_str = ("SHOW: Game of Thrones 7:00 PM EST\n"
"SHOW: The Outsider 3:00 PM EST\n"
"SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.