const regex = /\bSHOW:\s+(.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bSHOW:\\s+(.*?)\\s+\\d{1,2}:\\d{1,2}\\s+[AP]M\\b', 'gm')
const str = `SHOW: Game of Thrones 7:00 PM EST
SHOW: The Outsider 3:00 PM EST
SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}