#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+(?=:::?)"
Local $sString = "doc_name <-" & @CRLF & _
" officer::read_docx() %>% " & @CRLF & _
" flextable:::body_add_flextable(table_to_save) %>% " & @CRLF & _
" print(target = "word.docx")" & @CRLF & _
"" & @CRLF & _
".libPaths()" & @CRLF & _
".test()" & @CRLF & _
"" & @CRLF & _
"c("a", "b")" & @CRLF & _
"" & @CRLF & _
"package::function()$field"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")