re = /\w+(?=:::?)/
str = 'doc_name <-
officer::read_docx() %>%
flextable:::body_add_flextable(table_to_save) %>%
print(target = "word.docx")
.libPaths()
.test()
c("a", "b")
package::function()$field'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end