import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?=:::?)";
final String string = "doc_name <-\n"
+ " officer::read_docx() %>% \n"
+ " flextable:::body_add_flextable(table_to_save) %>% \n"
+ " print(target = \"word.docx\")\n\n"
+ ".libPaths()\n"
+ ".test()\n\n"
+ "c(\"a\", \"b\")\n\n"
+ "package::function()$field";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}