import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+, )\\1";
final String string = "0 @I@ INDI 1 NAME Anna /Von Hat/ 2 GIVN Anna 2 SURN Von Hat 1 BIRT 2 DATE 01 Jan 2000 2 PLAC Copenhagen, Copenhagen, Denmark";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}