re = /([a-zA-Z]+, )\1/m
str = '0 @I@ INDI 1 NAME Anna /Von Hat/ 2 GIVN Anna 2 SURN Von Hat 1 BIRT 2 DATE 01 Jan 2000 2 PLAC Copenhagen, Copenhagen, Denmark'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result