import re
regex = re.compile(r"([a-zA-Z]+, )\1", flags=re.MULTILINE)
test_str = "0 @I@ INDI 1 NAME Anna /Von Hat/ 2 GIVN Anna 2 SURN Von Hat 1 BIRT 2 DATE 01 Jan 2000 2 PLAC Copenhagen, Copenhagen, Denmark"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)