# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^DOSE:\s*([^-]*)-[^-]*-\s*(.*)/\1\2/gm;t' <<< "DOSE: 667 mg - TDS with food - Inject
DOSE: 667 mg - TDS with food - Tube
DOSE: 667 mg - TDS with food - PO"