// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^DOSE:\s*([^-]*)-[^-]*-\s*(.*)").unwrap();
let string = "DOSE: 667 mg - TDS with food - Inject
DOSE: 667 mg - TDS with food - Tube
DOSE: 667 mg - TDS with food - PO";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}