import Foundation
let pattern = #"^DOSE:\s*([^-]*)-[^-]*-\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DOSE: 667 mg - TDS with food - Inject
DOSE: 667 mg - TDS with food - Tube
DOSE: 667 mg - TDS with food - PO
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)