import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "page=\"[0-9]+\".+?subject=\"(?:Text Box|Sticky Note)\".+?<\\/span";
final String string = " ><text color=\"#FFFF00\" creationdate=\"D:20180307100631+04'00'\" flags=\"print,nozoom,norotate\" date=\"D:20180307100652+04'00'\" name=\"a60915a3-1c23-4f6d-b8d4-fbe0dd4890e9\" icon=\"Comment\" page=\"7\" rect=\"351.308000,135.732000,371.308000,153.732000\" subject=\"Sticky Note\" title=\"saddia\"\n"
+ "><contents-richtext\n"
+ "><body xmlns=\"http://www.w3.org/1999/xhtml\" xmlns:xfa=\"http://www.xfa.org/schema/xfa-data/1.0/\" xfa:APIVersion=\"Acrobat:9.0.0\" xfa:spec=\"2.0.2\"\n"
+ "><p dir=\"ltr\"\n"
+ "><span dir=\"ltr\" style=\"font-size:10.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"\n"
+ ">As agreed with WPO that any unspecific area use GEN</span\n"
+ "><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#1D477B;font-weight:normal;font-style:normal\"\n"
+ ">
</span\n"
+ "><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"\n"
+ ">
</span";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}