import re
regex = re.compile(r"page=\"[0-9]+\".+?subject=\"(?:Text Box|Sticky Note)\".+?<\/span", flags=re.DOTALL)
test_str = (" ><text color=\"#FFFF00\" creationdate=\"D:20180307100631+04'00'\" flags=\"print,nozoom,norotate\" date=\"D:20180307100652+04'00'\" name=\"a60915a3-1c23-4f6d-b8d4-fbe0dd4890e9\" icon=\"Comment\" page=\"7\" rect=\"351.308000,135.732000,371.308000,153.732000\" subject=\"Sticky Note\" title=\"saddia\"\n"
"><contents-richtext\n"
"><body xmlns=\"http://www.w3.org/1999/xhtml\" xmlns:xfa=\"http://www.xfa.org/schema/xfa-data/1.0/\" xfa:APIVersion=\"Acrobat:9.0.0\" xfa:spec=\"2.0.2\"\n"
"><p dir=\"ltr\"\n"
"><span dir=\"ltr\" style=\"font-size:10.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"\n"
">As agreed with WPO that any unspecific area use GEN</span\n"
"><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#1D477B;font-weight:normal;font-style:normal\"\n"
">
</span\n"
"><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"\n"
">
</span")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")