// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)page="[0-9]+".+?subject="(?:Text Box|Sticky Note)".+?<\/span"#).unwrap();
let string = " ><text color=\"#FFFF00\" creationdate=\"D:20180307100631+04'00'\" flags=\"print,nozoom,norotate\" date=\"D:20180307100652+04'00'\" name=\"a60915a3-1c23-4f6d-b8d4-fbe0dd4890e9\" icon=\"Comment\" page=\"7\" rect=\"351.308000,135.732000,371.308000,153.732000\" subject=\"Sticky Note\" title=\"saddia\"
><contents-richtext
><body xmlns=\"http://www.w3.org/1999/xhtml\" xmlns:xfa=\"http://www.xfa.org/schema/xfa-data/1.0/\" xfa:APIVersion=\"Acrobat:9.0.0\" xfa:spec=\"2.0.2\"
><p dir=\"ltr\"
><span dir=\"ltr\" style=\"font-size:10.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"
>As agreed with WPO that any unspecific area use GEN</span
><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#1D477B;font-weight:normal;font-style:normal\"
>
</span
><span dir=\"ltr\" style=\"font-size:11.0pt;text-align:left;color:#000000;font-weight:normal;font-style:normal\"
>
</span";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}