#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<table\b.*?\bclass\s*=\s*(['"]).*?\btest\b.*?\1.+?<\/table>"
Local $sString = "<table class="test">" & @CRLF & _
                "<tr>" & @CRLF & _
                "<td>bla bla bla</td>" & @CRLF & _
                "</tr>" & @CRLF & _
                "</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")