# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=notes:.*?)\b\d{1,2}([-\\/])\d{1,2}\1\d{4}\b/<br> $&/gm;t' <<< "wed and thurs and notes: are just so interesting 02-03-2019 on a new line please 04-05-2020 on another line please wed and thurs and notes: are just so interesting 02/03/2019 on a new line please 04/05/2020 on another line please"