$re = '/(?<=notes:.*?)\b\d{1,2}([-\/])\d{1,2}\1\d{4}\b/m';
$str = 'wed and thurs and notes: are just so interesting 02-03-2019 on a new line please 04-05-2020 on another line please wed and thurs and notes: are just so interesting 02/03/2019 on a new line please 04/05/2020 on another line please';
$subst = "<br> $&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;