const regex = /(?<=notes:.*?)\b\d{1,2}([-\/])\d{1,2}\1\d{4}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=notes:.*?)\\b\\d{1,2}([-\\\/])\\d{1,2}\\1\\d{4}\\b', 'gm')
const str = `wed and thurs and notes: are just so interesting 02-03-2019 on a new line please 04-05-2020 on another line please wed and thurs and notes: are just so interesting 02/03/2019 on a new line please 04/05/2020 on another line please`;
const subst = `<br> $&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);